Baxi Neta-Tec fails Calibration

Long shot here, perhaps?
This boiler has no error codes but flames out with what looks like insufficient gas on a modulated lowish output and purges before restarting.
Placed the boiler in calibration mode and it runs nicely at 100% but flames out when on a lower output %, then a purge and the whole calibration cycle starts again.
This will happen as many times as you let it until you kill the power. No error codes or other indication of a problem.
These Baxis seem to be renown for faulty gas valves and would this be the likely cause?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 16/05/2019 00:41, Fredxx wrote:

Has no one got the bottle to work on a boiler? :-)
It was the gas valve. The valve has two solenoids. One is a gas shut-off, and the other is the modulating valve. The valve has 24V on the label.
The shut-off valve opens at around 8V and closes at 1.5V
The modulating valve starts opening at ~6V and fully open at ~8V (very approx).
The old valve, when blowing through it, moved in steps, where there was hysteresis in the flow rate. The new one opened cleanly and without any perceptible steps in flow rate.
It now works, no flame-out with subsequent purge cycles.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.