Kenmore Elite Dishwasher Troubleshooting....HELP!!

My dishwasher in not working. It will pump water into the bottom of the washer but will do nothing with the water after that. The water will not make its way up to the sprayers at all. It also makes a very loud noise when trying to pump up to those sprayers. I have looked at the functional spec's of the washer a few times and run through the diagnostics and I feel that I have successfully segmented the issue to either a fill valve issue or a fuse of some sort. I am hoping to get a few other ideas from you experts out there. I know this has to be a common problem and I am not about to spend $100 just to get a service person out here.
Can anyone help me with this issue?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check out www.appplianceaid.com www.repairclinic.com Could be the pump is not pumping if the motor is running.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
http://www.repairclinic.com/0047_9.asp
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check pump for debris, thats the noise you hear.
fill valve is fine, since its full of water. noise tells us water level sensor swutch is good too.
bad or debris in pump
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.