Moen shower control problem

Hello,
I've just installed a single lever Moen shower control...the problem is that the control actually "sucks' back into the assembly resulting in no or little water flow when the control is set to midway between hot and cold. Any insight on this one? TIA
AJ
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
if it were me, and i just bought it, i'd take it back.
randy

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
AJ,

I just finished installing some Moen shower faucets myself. One of them was like yours, just a trickle of water. I fixed the problem by disassembling the valve, and cleaning out the little pressure balance piston inside. Probably just clogged with plumbing debris. Once it was cleaned and reassembled, it worked fine.
Since this is described in the installation instructions, I assume it's a fairly common problem.
Oh, one other possible cause, the handle could be on upside down.
Anthony
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
HerHusband ( snipped-for-privacy@unknown.com) said...

I would suspect that as well. Moen's instructions describe flushing out the water line with the cartridge removed before using it for the first time in order to avoid this.
--
Calvin Henry-Cotnam
"Never ascribe to malice what can equally be explained by incompetence."
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.