Kenmore (Whirlpool) HE3-T Front load washer

My Kenmore HE3T front load washer (3 years old) squeaks while rotating during the wash cycle. It has done this occassionally when the washer hadn't been used for several days but usually it stopped after a few minutes of washing. Today it is a bit louder and so far hasn't stopped. Does this sound like a simple problem (needs new belt or oiling some place) or something more sinister (bearings going bad already). Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Art wrote:

Depends on the type of squeak. If it makes the most noise right as it starts to turn then it is most likely a slipping belt.
Checkout http://www.davesrepair.com/DIYhelp/DIYwshbelts.htm
for "more than you wanted to know about washing machine drive belts."
Hope that helps.
--
_____________________________________________________________________
Richard Thoms
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It keeps squeaking for several minutes of front loader washing. I think it is just from things inside drying out. I keep the door open on the washer between loads. That is a new habit for me and I think it lead to the squeaking as I reflect on the issue.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.