Whirlpool Fridge Freezer Water Fillter query

Anybody able to offer advice?
We've got a Whirlpool Fridge Freezer (double door, upright, american style). The water filter registered as needing replacement on Christmas Eve, didn't get round to it until this week, got 3 filters from Whirlpool (78) inserted one, and ran off 14 litres as per manual, got a bit of air through as it said we should, but the LED disply on the door says the filter needs replacing. I've had it out and put back in again several times, turned power supply off for about ten minutes hoping it will reset. Whirlpool's servive line isn't open this morning, anybody know what the problem is?
regards
IanC
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The appliance doesnt

The appliance doesn't know you have changed the filter it needs to be reset on the control panel, refer to your instruction book. The indicator doesn't sense how restricted the filter is, it is just a usage/time indicator similar to a car needs a service indicator, this is reset after the operation is carried out. Peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Peter
Thanks for the reply, but it doesn't have any reset button as far as I can see, will contact the service centre
regards
Ian Clarke
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

On my Whirlpool side-by-side, to reset the filter indicator, you press the switch that controls the interior light 5 times within 10 seconds. The filter indicator then changes from red to green.
BTW: the filters (official Whirlpool) are one third of the price from the US and fit just fine. Pattern filters are even cheaper.
--
(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mike, whilst the light button didn't do it, played around a bit, the answer is hold the OK button in for about 5 secs, it then resets.
Thanks to all for advice given.
regards
IanC
writes

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.