Problems installing mortising attachment

I have just bought a new drill press, the General International 75-025, and am trying to attach the General International 70-900 mortising accessory to it. Whenever I turn the unit on with the mortiser installed, it spins a couple of seconds and then the arbor and chuck fall out of the quill.
I have followed the instructions for installing the arbor and chuck and the drill works fine with an ordinary bit installed. As far as I can tell everything is correctly set up. The rather brief instruction manual contains no trouble-shooting guide.
Is there a way to install the arbor in the quill more positively? Could there be something wrong with the mortising bit? Alignment?
I would appreciate any help on this as I am new to this kind of setup.
Best Regards, Jack Fearnley
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hello Jack, I'm not going to pretend I know the problem since I am unfamiliar with the set up you have but on my bench top mortiser - A Delta model- I have to set the chisel a few milimeters away from its "home position" using a shim, install the drill bit in the chuck, and then reseat the chisel to its true position after removing the shim. Does your chisel require this same postioning procedure? I'm curious to know if the drill bit is rubbing against the bottom of the chisel. Marc
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
jack wrote:

Make sure the arbor and the quill are clean and free from oil/grease. Clean them with something like acetone, naphtha, etc.
--
Jack Novak
Buffalo, NY - USA
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Google "chuck falls out", using the quotation marks. You will find many usefule hits. I think it's the "rattling" of the mortiser bit in the chisel that shakes it loose. Whereas the down pressure of pushing drill bits serves to force the parts together.
Pete Stanaitis ---------------
jack wrote: Whenever I turn the unit on with the

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Many thanks to Marc Rosen, Nova and spaco! It's true, I had omitted the cleanup with acetone. Once that was done I tried again with the 1/2" bit. Same problem. Perhaps it is out of alignment. The auger does seem to rub against the chisel. I then tried the three smaller bits and they work fine, so it must be that either there is something wrong with the 1/2" or it's too heavy.
Marc, how do you shim the bit exactly? I stabbed myself twice in the hand fiddling with the bits. Those chisel tips are plenty sharp!
I had already googled loose chuck but it didn't address my particular problem. Using "chuck falls out" was more productive.
One of the problems I have is that, in order to remove the mortising attachment, I have to remove the chuck. So I don't want to make it too tough to remove. Maybe after a couple more days I can figure out a way around that.
Thanks again, Jack Fearnley
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Marc, how do you shim the bit exactly? I stabbed myself twice in the hand fiddling with the bits. Those chisel tips are plenty sharp!
Hello Again Jack, Here is how I set up my benchtop mortiser; I set the clearance by inserting a dime between the shoulder of the chisel and the mortising chuck and lightly tighten the chisel in place. Then I insert the drill bit into its chuck until the flutes barely touch the chisel points. (On some units you may have to install both chisel and drill bit at the same time because of depth clearance). Next, I loosen the chisel and (with the dime safely back in your pocket, or piggy bank) push the chisel up into its chuck and retighten securely. The gap introduced by the dime is now the clearance between the drill bit flutes and the chisel points. For good measure, use some type of dry lubricant on both bit and chisel- inside and out- before and during the mortising operations. After the propellents dry, the lubricant will not affect the wood or alter its subsequent finish. I think Elmer makes a good dry spray lubricant in addition to their spray adhesives. (I'm not joking here). Hope this helps, if not type back. Marc
(And just so I don't get sued for plagiarism by my best friend Brian Graham, of the Cayce Company, I am referencing his Fine Woodworking article from May 2002 for some of the terminology above. The piggy bank comment is mine.)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.