Delta 10" Radial arm saw

Have a Rockwell delta , When the saw head is moved back and forth to cross cut it feels rough, I checked the bearrings and they seem fine and the 2 tracks that they ride in are smooth and clean.
Any ideas would behelpful Thank You in advance
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Lube?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
audiowood wrote:

The tension of the rollers on the tracks should be just enough to provide a slight resistance when pulling the motor without any side to side motion. It should ride very smoothly. The rollers have an off centered mounting hole to allow for the tension adjustment. If there is no side to side play, the rollers may be adjusted too tight. If there is any side to side motion, the rollers are too loose. make sure the rollers are turning and not sliding when you pull the motor along the arm.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 7 Apr 2010 14:26:50 -0700 (PDT), audiowood

Does it feel rough when sliding the saw head, but not cutting wood or is it just rough when cutting the wood?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.