Bachhoe Problem

I have an older JD Backhoe w Extendahoe, My problem is that when I start it it will run for about ten minutes and then die, (Like starved for Fuel.) I have cleaned the Tank, Pick up filter, fuel pump screen, fuel filter, and changed the fuel lines. The pump is a new electric one and seems to be pumping more then enough fuel. I am dumbfounded and would appreciate any guidance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@tbaytel.net wrote:

Injectors?
How does it die -- sudden or slow death? How does it run until then? Not enough data...
--


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'd sell it cheap to me ;-) I need one...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Go over to alt.fan.tractors.
I'll bet some one over there can give you an answer.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Jun 18, 1:12 pm, snipped-for-privacy@tbaytel.net wrote:

I had the same problem years ago and it was either a check valve or restrictive fitting on the fuel pump (I think on the return side) that I replaced and that cured it. If it has a fuel shut-off solenoid you might want to check that system out as well (I think there's a relay/ circuit breaker under the instrument panel. Good luck.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Needle valve sticking?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Had an older Ford car that did the same thing. Turned out the coil, for some reason, became heat susceptible. Same symptoms, ran fine until engine warmed up. Replacement of coil did the trick. Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dave wrote:

One would certainly not assume this is a gasoline engine so coils and needle valves are pretty much out, methinks...
The check/backpressure valve, cutoff solenoid, injectors, etc., otoh, are possibilities. Also I'd assume by now the problem is solved or OP has gone elsewhere...
--
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.