Electic Boiler / Economy 7 problem

I have an electric boiler and heating linked to economy 7, with a boost if needed.
The water tank heats up nicely but no hot water comes out, only cold! I moved in a week ago and haven't had a proper shower yet!!!
Can anyone shed any light on what might be wrong. I've had a plumber in who says he can't see anything wrong, and an electrician who said the same. They told me to contact Norweb who put the system in and they don't deal with this stuff any more.
Any ideas gratefully recieved.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Can you take a picture and put it on the web? If not, can you read any markings or manufacturer's name and model?
How do you know the water cylinder heats up?
The system could be a heat bank. In this type of system, the hot water doesn't come directly from the cylinder. Instead, when you open a tap, the mains pressure water activates a flow switch which pumps the stored hot water round a heat exchanger, heating the incoming water. If you have such a system, the following failures (amongst others) could cause the hot water to run cold:
1. System is turned off (probably at an FCU). This won't affect heating the cylinder, only the transfer to the cold mains.
2. Pump failure.
3. Flow switch failure.
4. Heat bank cylinder needs topping up (manual fill).
5. Heat bank cylinder refill failure (auto fill)
Christian.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.