Boiler/Timer Woes

Hi there
I have a Sunvic SP35 control box (timer?) attached to my Glowworm Economy central heating boiler.
I turned the SP35 off at the mains last night, and it's been off for about 24 hours. I've now turned it on again and the LCD is coming on, but it won't accept any input (such as trying to set the time, activate the boiler etc). Can anyone think about why this is? I've also tried leaving it for 10 minutes, and also re-lighting the boiler!
Sorry to sound so totally DIY dumb!
Tobes
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Additional info...
I tried changing the fuse, but with no difference. When the controller is off at the socket, the LCD panel dims, and when I turn it back on, the panel gets brighter/stronger. This suggests there is mains power getting to it, but the buttons aren't working!
Is there a way to reset the box?
Cheers,
Tobes
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ok, hit the FAQ on the Sunvic website. It said to disconnect from battery pack.
So, removing front panel and reattaching seemed to reset it!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.