weird toilet problem

Old type gravity flush toilet. Pull handle, tank empties, all is well. However, then the water fills the tank *very very* slowly. Almost not at all. BUT if I turn on the water in the adjacent bathtub, the water starts flowing into the toilet tank at a fast, normal rate!! (of course there is water flowing into the tub too. :) Could this be some type of pressure lock on the water pipe. If so, is that easy to fix? Getting a plumber down here in New Orleans is almost impossible. Any ideas?? thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
lestrade wrote:

More than likely the ballcock (fill v alve) in the tank is shot. A few designs were very sensitive to pressure changes like you have.
Depending on the mfr, you may be able to put in a repair kit and not have to change out the whole valve. See what's up there.
Jim
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
lestrade wrote:

If reduced water pressure solves your problem, you should be able to get a temporary fix by shutting down toilet supply valve. Flush the toilet and start shutting off supply to toilet until the water starts flowing better. But, I agree a new valve is likely the fix.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I know this is non-responsive, but I closed that valve way down so that it takes 5 or 10 minutes or more to fill the tank, but I don't hear any noise anymore, so it's worth it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, guys!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.