go kart engine trouble

i just got a go kart that has been sitting for two years. it won't start. i pulled the spark plug and pulled the string, no spark. i put a new spark plug in, still no spark. i held the live wire with my fingers to see if there was anything, and i felt a spark. however, every time i attached it to the plug, nothing.
so i figure weak spark. i take apart the whole string start thing on the side of the thing looking for the points, i then realize the points are outside under a little metal covering. i put it all back together, halfassedly, but it still pulls enough for a start. i found the points, cleaned them. still nothing. now there is no spark at all. i didn't put two screws back on the big fan thing that's connected to the crank shaft, that's the only thing i can remember not doing when putting it all back together.
what can i do to get this thing to run?
also, i was told it needs a new clutch. how and where is the clutch on a go kart???
thanks!!!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You are touching the spark plug threads to the engine block when you look for spark, aren't you?

Without knowing what engine you have we can only guess.
Where is the sensor for the ignition at? Is it possible that you've got the timing way off now?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote in

Clean out the old,gummed out fuel,put fresh gas in,clean the carb with carb cleaner. If you removed the points,you may not have aligned them properly when you reinstalled them. It could also have a bad magneto coil,or bad plug wire.

the clutch is a centrifugal clutch,on the output shaft of the engine,usually with a chain drive to the rear wheel.It engages when engine RPMs spin fast enough. It's round,metal,with a toothed gear on it.
They wear down and begin to slip.
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote in

If it were putting out enough voltage,the pulse would REALLY zap your whole arm,enough to hurt.
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 06 Jun 2007 12:15:57 -0700, fuhgettaboudit02 wrote:

Pull the flywheel and replace the shear key. Reset the points per factory specs. About all you can do except replace the magneto which almost never go bad.
--
#1 Offishul Ruiner of Usenet, March 2007
#1 Usenet Asshole, March 2007
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 06 Jun 2007 12:15:57 -0700, snipped-for-privacy@gmail.com wrote:

Then you probably had a spark.

That's why Noozer asked what he did.

Was this two years ago? Otherwise, how could they know you need a new clutch if the engine isn't running?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Not one good enough to fire an engine. YOU grab an ignition wire and see how it feels;it will zap your whole arm and your shoulder too,if it's a good spark. And you definitely will not want to do it again.
(my personal experience with MY mini-bike;it "shut off" by pushing a grounding clip against the spark plug,and I reached under the seat to do it without actually LOOKING at what I was doing,made contact with the tip of the spark plug instead of the clip,and ZAP,I raised up like someone set off a firecracker under my butt.It HURT,and I was shaky for a minute or two.I imagine that is what being zapped with a TASER feels like.)

Maybe the last time they tried to use it when the engine -was- running,the clutch was slipping. Then they let it sit for 2 yrs,and then decided to sell it "as-is".
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I figured either it was a strong spark but he didn't say so (people are always leaving out important stuff, or he assumed spark was equal to strong spark), or he wasn't conected to the go-cart anywhere else so the spark felt weaker.
I got to the point where shocks from my car's spark plug wires, while I leaned against the fender, weren't so bad that they made me pull back my arm.

Oops. I missed this.

Maybe.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Testing a small engine/old auto points condenser was fun. Think that it's bad? Pull a plug wire from your car engine and slightly attached the condenser to the plug and wire. Do not let it ground. Crank the engine, run a moment and turn off. Remove condenser, holding the wire and toss it to a friend...hey catch!. If you like; just cup the condenser in your hand. It BITES! :-)
-- Oren
"I didnt say it was your fault, I said I was blaming you."
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 06 Jun 2007 12:15:57 -0700, snipped-for-privacy@gmail.com wrote:

With the plug out, connected to the wire and resting against metal (ground) pull the cord and look specifically for the type of spark you have. Yellow/Orange would indicate a weak spark. A nice bright blue (with the snap snap) is what you want.
I've seen a weak spark when flywheel magnets corroded a bit with rust. They can be cleaned with a little 220 sand paper.

Check the gap on the points. first....

Buy this after the engine runs :-))

-- Oren
..through the use of electrical or duct tape, achieve the configuration in the photo..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.