Front Load Washer problem

Please forgive me if this posts twice, cuz my computer said it wasn't sending. Not sure if it did or not. On my Kenmore 43142 front load washer, the fabric softener and bleach no longer go into the washer. I have had fabric softener in that little dispenser for over two weeks now, and it never empties. Same for the bleach dispenser. Sears and Kenmore.com are no help at all. No troubleshooting on their site. Guess they want you to pay for a repairman. Anyone have any ideas? I can't find the user guide in my house, and there's nothing like that available online, either. sigh... Thanks for any advice...
Patti (there's also a musty smell always eminating from the washer, and I know it's from water stuck inside. anyway to keep that from happening?)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Get it repaired? That's why they have repairmen.
--
Wayne in Phoenix

unmunge as w-e-b
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have had the same problem with my washer. I did two things. The drawer that hold the bleach and softener "cups" pulls out. Pull it out and clean all the gunk out. Also found that the water hoses going into the back of the washer were clogged up with grit from our well (at the washer/hose junction). Cleaned out the gunk and everything worked fine. I suspect that while there was enough flow to fill the washer, perhaps not enough to rinse out the little "cups".
B

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.