Septic Pump not Pumping

I just had my septic tank pumped and it less then 1 week the septic pump stopped working. I opened the pump chanber and turned on manually the pump - I can hear the humming of the pump but the water level is not changing.
Any suggestions of what is causing this? Does the pump need priming somehow? Or it got jammed?
Tom
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The pump should be sitting up on something to keep dirt and small rocks from getting into it. It sounds to me like either the pump or the line is jammed

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There is probably some shit down in there.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Oscar_Lives wrote:

Thank you for the responses. I took the pump out, inspected then put it back and now it works. Not sure what it was.
I'm wondering if it was some air on the discharge pipe causing the problem. I heard that some installers drill a small hole on the side of the discharge pipe to allow it to drain after each pumping. I'm wondering if that would have helped to have.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.