Please help diagnose Whirlpool washer problem

Our Whirlpool washer kicked off the circuit breaker and had a hot "electrical" smell - although not a real strong smell. I turned on the breaker and now all it wantsto do on the different cycles isagitate (the water that was still in the tub when it quit). I removed some water to see if it would run more water in, but it just agitates. On the part of the timer where I think it should pump out the washer is silent - no humming. Agitate or silent that's all it does.
Funny thing is 2 days ago we got a new basket to replace the old one that had some rust around some of the holes. The basket is still in the box and I think I can return it ($115) if this washer isn't worth fixing.
It is about 15 yrs. old and is a model LSP8244BWO.
I suspect the timer, but am not at all sure. Pump? Solenoid?
Any ideas about fixing (or junking) this washer would certainly be appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Forgot to mention this is the first problem we ever had with this washer other than replacing the timer knob. Seems to be in good conditon otherwise, but I don't think we should spend much more than the cost of the basket to fix this thing.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.