Perplexing Hot Water Problem

Last week we installed an electric tankless hot water system. Everything worked as expected for several days, so we know things were hooked up right. For the last couple of days there has been a strange hot water problem that no one can figure out. Here's what's happening: Hot water will only come out of the kitchen sink, but only if the bathtub is running full blast. Hot water will not come out of the kitchen sink if the tub is not running. The hot water to the kitchen sink does not cut out as long as the bath is running. Hot water will not come out of the tub valve or the valve in the bath sink at all now. Hot water will go into the clothes washer for a few seconds and then goes cold. IOW, the only hot water in the house goes to the kitchen sink, and then only when the tub is running. Other info: the bath valve is a single-control type. we tried replacing the mixing valve in the tub twice; no effect. we looked under the house to see if there is a hot water line leak, but there isn't. the tankless co. is sending out a new unit in case that's the problem. Does this make sense to any of you? Any theories?
cyd ropp, homeowner
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
cyd wrote:

I don't have one personally but I have heard these things switch on at a certain flow rate. So there is probably a flow rate detector thingy in the heater that is broken. So its not properly detecting flow rate. So its not heating fast enough to match the flow rate. I think the heater is broken. Still could be a hookup problem.
CL
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.