kenmore washer agitator problem

Hello, I have a Kenmore series 80 Washer _ like new condition.
However, after recently moving I'm having trouble with the agitator. The machine won't agitate correctly any longer. If I have a small load with not much in it its fine, however, a larger load with more weight seems to bog down the agitator. It works but its hardly turning.
I took the spinner off and re-attached a bit tighter. It helped a bit but hasn't solved the problem.
Any ideas what the problem might be and is this a repair I could easily do myself?
Thanks
Could you please reply to snipped-for-privacy@shaw.ca
Glenn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
im guessing but maybe a loose or missing spring? im guessing you havent got to a spin cycle yet and thats not working either. im guessing.
randy

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi,

Model#? http://www.applianceaid.com/model.html Some model# helps.

Some -common- agitator trouble makers.... http://www.applianceaid.com/direct.html#agitating Sometimes the inside of the agitator can wear out and the agitator will no longer go back and forth to wash, also the metal transmission shaft can rust and wear away.
http://www.applianceaid.com/images/inostransshaft.JPG
jeff. Applaince Repair Aid http://www.applianceaid.com /
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.