Husky Power Washer HP 1500

I bought one of these about a year ago. Used it less than six times, and went to use it yesterday, and it wouldn't power up. Called the 888 number, and they said it needed a rebuild pump kit for $$. I said I had only used it less than six times. They said they would send me a rebuild kit, but only one, and only THIS time. And I have to fix it.
Anyone have one of these, have experience with this, or know how this would not work in such a short time? Drained after each use, kept indoors.
Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
SteveB wrote:

It's not something silly like a tripped GFCI or breaker is it? The small electric units are the bottom end of pressure washers, so they aren't built for longevity. Feeding oil into the pump before storing helps prevent internal rusting and seizing. Have you actually diagnosed what's wrong with it?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yeah, was on the phone with the tekkie twice. It powers up. I take off the hose, and water flows through and out the outlet. I turn it on, and no increase in the pressure coming out, even though the motor runs. They sent me a rebuild kit, but I don't want to tear it apart until I have the kit to fix it. I have had other cheapo models that lasted and lasted until the hose froze, or the hose hook up corroded so bad it was unusable. Never had a pump go out before, and with such minimal use. I'll see once I get in there, maybe it can be fixed with some new o rings or something easy and simple. They can't be complicated. I rebuilt my Graco XR7 airless sprayer.
Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.