craftsman riding mower belt problem

I have a craftsman DLT 25 hp riding mower. The drive belt keeps coming off. I bought a new belt and still have the same problem. It happens when I stop and shift from a forward to reverse. Any ideas? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a craftsman DLT 25 hp riding mower. The drive belt keeps coming off. I bought a new belt and still have the same problem. It happens when I stop and shift from a forward to reverse and then back to a forward gear. Any ideas? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You have a common case of pulley misalignment. One or both of your pulleys is shifting position from wear, poor design or whatever. Some designs are using stamped sheet metal mounts that are quite flimsy. If you would rather mow than play with belts, get a Kubota or Simplicity if you prefer American made. Good luck.
Joe
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bent or worn pulley. Bad bearings on pulley shaft.
--
______________________________
Keep the whole world singing . . . .
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
padavid12 wrote:

Maybe the belt is too long? Check the idler pulley spring.
--

dadiOH
____________________________
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
padavid12 wrote:

Guard misplaced/bent/missing???
--


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
dpb wrote:

brake was engaged. I took the keeper off, adjusted it, and put it back on. It seems to be fixing the problem. David
--
Message posted via HomeKB.com
http://www.homekb.com/Uwe/Forums.aspx/repair/200804/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
padavid12 via HomeKB.com wrote:

Am I good or what???!!! :)
Glad it helped.
-d(uane)pb
--


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Please let us know when it's done. ;-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
DerbyDad03 wrote:

--
Message posted via HomeKB.com
http://www.homekb.com/Uwe/Forums.aspx/repair/200804/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.