Compactor with cycle or motor problem

Kenmore Compactor, 15 years old. It recently started doing a "fast cycle" up and down. I pulled the covers and the ram goes down maybe 1/2" then reverses, then down, until it has done this 20 times and it shuts down. You have to wait five minutes, then try it again. Seems like it overheats and pops some safety on the motor, when it cools it works again.
I pulled lots of trash out form around the plunger but that was not the issue. It's clean now. Also, the door tilt switch was smashed. I thought that was the only problem, but removing it and jumpering it out still leaves me with the up/down cycle problem.
Perhaps when the tilt switch broke it caused a motor control/cycle problem ? Any pointers to how I should test ? I have the factory test instructions and I confess to not doing all the tests yet aside form the two door switch tests (one passed, one now jumpered out). I am hoping someone can give me a pointer that will save me some test time.
thanks,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 11/18/2004 11:44 PM US(ET), Retro Bob took fingers to keys, and typed the following:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

I'll give that a shot. I'm going to pull it all apart and run through all the diagnostic tests this weekend to see if I can shake something out. I have this bad feeling that it's the motor controls but it really does seem mechanical. I'll have to dig deep.
Thanks, Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.