Admiral AC resets

The admiral AC unit we have resets itself after a couple of days. My mother says it resests when it's not on or not running. This is on the plug which is connected to a 3 prong outlet.It says on the plug that if it resets it's a problem, but I'm not sure since it occurs when it's not on. I noticed it says in the manual that you should have a electrician verify the plug is grounded, we never did that as it was not obvious and buried in the manual someplace.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like there is a GFI somewhere in there that is tripping.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How can you diagnose? At this point, we don't really know what the thing is doing. It could be the thermostat is going click, it could be that the unit is cycling off on high limit switch, it could be cycling on overload. It could be....
I'd love to hear how you got that answer. Are you psychic?
--

Christopher A. Young
You can\'t shout down a troll.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You're really going to have to give us some more information. Quit trying to talk scientific, and just tell us what it's doing. Or not doing. "resets" means different things to HVAC professionals, versus the rest of the world. There is very clearly not enough information for us to even guess, much less write anything helpful. YOu get to write the next post, and then I'll ask some very, very specific questions.
--

Christopher A. Young
You can\'t shout down a troll.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What info do you need ? There is a green light on the plug itself (the 3 prong plug that goes into the wall). There is also a reset and test switch on the plug. When the unit resets, the green light goes off. You hit the reset button, it's back on and the unit will work.
Stormin Mormon wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.