small engine trouble

I have a 25cc Homelite weedeater that is about a year old with little usage. It suddenly will not "get up to speed" It will idle perfect, starts very easy, It is just when you try to give it full throttle it boggs down. I have cleaned the spark plug and air filter.(they looked good) I started to adjust the carb but it was running great yesterday and it still idles perfect. Any suggestions as to what is causing this. I even mixed up different gas just to make sure the gas was fresh.
--
Rob



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hello, you might want to take the 4 bolts off the front of the engine and seperate the engine from the shaft. look at the govenor weights and springs to make sure they are not broke
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Rob wrote:

Quite possibly a speck of dirt caught under the high speed needle. Go ahead a try adjusting it, keeping track of how much you turned each way. (or bottom each needle, noting how many turns it took to get there) Adjusting it may dislodge the dirt. If tweaking doesn't help, you can always position the needles back as they were and look elsewhere.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Remove or clean the screen in the muffler, it is plugged. It is there as a spark arrestor. To much back pressure.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

BINGO!! That was it. Thanks a lot. Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

your welcome:)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.