Briggs 3.75 motor

I have a Briggs on a MTD mower about 2 years. When you start it it runs like the choke is on. It has the little primer bulb. It is running way to rich but there is no adjustment on the carb. In fact the carb is more or less sealed. I have put in fresh gas and changed the plug. Any ideas?
From Mel & Donnie in Bluebird Valley
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
if its the kind of engine that has the gas tank bolted to the bottom of the carb, the the rubber gasket between the tank and carb needs to be replaced,. its called a carb diaphram.ive fixed many doing what yours is doing .youll need the engine model and spec number stamped on the sheetmetal covering the top of the motor to get it or just take the old gasket with you to match up..lucas
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I took it apart and seen the rubber gasket you are talking about, I cleaned it and put it back together and it is running good now. Must have been a speck of dirt somewhere - THANKS - If it does it again I will get a kit.
From Mel & Donnie in Bluebird Valley
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
that rubber gasket isnt just a gasket, it pumps fuel.if it get stretched or distorted it acts up,pumps to much or pumps to little. lucas
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.