Intertherm gas forced hot air furnace.

I have a intertherm gas fired hot air heating A/C system and yesterday the system quit responding to the thermostat no fan no a/c no heat. I checked the pilot light to see if the pilot light was on and it was and if I hit the air circulation fan switch on the control box on the inside of furnace the fan works. I pulled the thermostat cover and moved the heat setting up to niney and looked for a spark in the mercury switch inside and there was none I repeated lowering the setting to cold and moved it uop again and no sark in the mecury switch. I have worked on oil fired heating in past and you always see a spark in the mercury switch but not this gas fired unit unit soi I opened the control box looking for a possible wire off of terminal and evcerything seemed where it belonged I saw two what appeared to be relays in the box but know nothing about this system so I could use some info from someone who may know what to look for next.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 24 Dec 2007 09:14:36 -0800 (PST), Auto Tech

IF you are an "Auto Tech" and you know all about the little "spark" in the glass bulb then you dont need our help in here. You are already way beyond us. Maybe NASA can help you? Bubba
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.