Carrier 58hdv100

Hello,
I installed a new furnace to my house. It works fine, but when the thermostat isn't calling for heat, the blower motor is making a noise. The noise is like a flourescent ballast. Is this normal? Also the LED blinking bright and dim but cant find what it means. All I know is that theres a code problem. Can someone tell me what the problem is? I cant find any installation guide for this particular model Eli ------------------------------------- Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Call Carrier thec. whatever it is, you need someone that is well familiar with that make and model. to me it sound that control does not fully shouts off on fan portion of control.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You need to call the competent, licensed, insured, professionally trained installer that put it in to diagnose and correct the problem. BTW... Most manufacturers warranties are null and void on all equipment that are purchased on the internet, and/or that are not installed by a licensed professional.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Often, the diagnostic codes are listed on the backside of the front furnace panel (s) . But youre going to need a Tech to do the repair with part, if required.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Cute, but on the Honeywell control board in my Quatro True Blue 90 alternating bright/dim is normal operation per the error code sticker. Obviously this doesn't mean that bright/dim is normal for all makes and models.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.