Smoke Detector Problem

I have a 2 year old house with Firex hard wired 120v smoke detectors that have a 9v battery for backup. My problem is that the detectors only work individually. I was told by the fire inspector that when any individual detector is tripped, all the others should beep simultaneously. I checked the wiring and everything appears correct. The interconnect wire is wired to all the detectors. I changed all the batteries. Then I removed some of the detectors and actually wired them together on the floor and I still can't get them all to beep. I tried all different combinations and no two detectors will beep together. The house passed the initial smoke detector inspection with no problems. Is it possible that all my smoke detectors have gone bad possibly from lightning or a power surge? I don't know what else it could be.
Tillio
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
That's my guess. Also try holding in the test button for a while, because with some new units, there is a delay before the signal is sent along the interconnect.

individual
to
problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It was the detectors. I replaced 6 of them. They were only putting out 3 - 6 volts on the interconnect lead instead of the required 9v. Thanks.
Tillio

individual
to
problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.