Problem with Motion Sensor Light Control

My Heath Motion Sensor has stopped working properly. It is stuck in the dusk position and will not switch to full lighting even though I see the sensor flashing as I walk by. The unit will go on full lighting if I put it into test mode, but only momentarily until it comes out of this mode. Do atmospheric conditions affect these settings, and what adjustments can I try on the control settings to fix this? Is it possible that the sensor is damaged?
Sherwin D.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like a bad photocell, I'd replace the unit as there are no serviceable parts

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Is the sensor window clean? Note the sensor is not the flashing part it is somewhere else nearby. Kevin
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Happy to report the Motion Sensor is working again. The solution was to increase the sensitivity setting from minimum to about 1/3 of maximum. Could be the sensor had lost some of it's sensitivity and needed the extra boost.
Sherwin D.
sherwindu wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.