barbeque burner...help !


Hi,all, my husband passed away a few months ago,and now I have joined the world of "home repair"...well.... kind of. Can anyone assist me in placing the burner ,with the venturi ,back into place in my Kenmore propane barbeque.
I noticed that one side section of the burner was not working properly...I had both sides on "high",but the flame on the right side was very low. Maybe something was plugged....!!!????
Later,when everything cooled,I removed all the grills,and lava,AND the burner to clean,and when I tried to replace the burner,I could not get the venturi tubes placed correctly over the orifices...is there a trick?
I went to the manual,but it showed connecting the venturi BEFORE the plate,and knobs were installed...do I have to remove the plate, and the knobs again?...I tried the knobs, and it feels like I will need a crowbar to remove them. Any suggestions are appreciated.
The barbeque has lots of years left Thanks,Rose
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I can't help with the replacement of the part, but: Believe it or not, there are spiders that will set up home in the burner tubes. Stores with a good selection of cleaning accessories sell a skinny brush specifically for clearing the tubes.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.