Aquastat Relay?

I am having a problem with my furnace it is a forced hot water system using old cast iron radiators. The burner will turn on when the thermostats call for it but the circulators will not turn on. If I tap on the aquastat relay (Honeywell L8148A0) a few times they will start for awhile usually until the burner lights again then the circulators will shut down again. Is there anything I can do short of calling a burner tech. It the relay repairable? What will it cost to have installed?
Thanks Scott
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Scott, your not giving enough info. To be using that relay, your boiler must be wired for cold start, which means the thermostats start the boiler rather than an aquastat. This control acts as a high limit and can be wired several ways depending on what equipment is on the boiler. You have more than one thermostat, so you should have additional relays on or around the boiler. Does the boiler make domestic hot water as well or is there a separate water heater? Under the circumstances, I think you'd be wise to call a heating tech

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is this the aquastat you have? This was the closest thing I found.
http://customer.honeywell.com/Techlit/Pdf/60-0000s/60-2278.pdf
It sounds as if the switching relay might be dirty or have corrosion on the contacts. you can try cleaning it, but shut the power first when you do.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.