Trend T5 Router bits coming loose

I've just tried using my new Trend T5 router with the DC400 dovetail jig but my bits just keep coming loose. I've tried an 8mm bit with an 8mm collet and a 6mm bit with a 6mm collet both keep coming loose after 30-60 seconds.
Thought it might be some little trick that i'm missing so i checked out the instructions. It says don't use excessive force when tightening the collet. I've even tried swinging off the spanner to get it tighter but whatever I do they still fall out. I've been routing for 5-6 years with my old Skill router no problems. What's going on????????
nobbly
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You're not seating the bit against the bottom are you? It shouldn't touch the bottom nor should it be in far enough that the radius at the top is in the collet. Both conditions will prevent it form holding.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have tried the bit in a little bit, half way and 3/4 of the way in. Could be a problem with the router itself.
Just contacted Trend Tech support (must say very good service) who offer to send a courier to collect the router from my house, repair it and then they will send it back repaired and free of charge.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.