ROS not so R anymore

My random orbital sander has gone a little wacko. After I clamped it in my vice to do some small pieces it hasn't been the same. It wants to run too fast and spins too much. I see some sparks but nothing real excessive. It does get hot now.
I took it apart and the brushes (or is it bushings, the little black square things pushed up against the shaft) are curved to the shape of the shaft and appear ok.
Any suggestions appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's possible that the braking mechanism has failed. You didn't say which ROS you have, but if you go here http://media.ptg-online.com/20031121102748_En913269-11-20-03.pdf on the bottom of pg 11 you can see how the brake on PC333 works. HTH.
Art

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I bet your right! It's a ryobi pos. But I looked up a place that shows it has a different type of brake on it. I'll have to take it apart again and see if it's fixable. The place I found it said they prefer some w/o brakes, that all's they do is keep them from spinning wildley between sanding but reduces performance while sanding. I think mine is harder to control. But maybe it's my imagination.
Thanks for your input

my
too
It
square
and
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.