Repairing Porter Cable hammer drill?

I've been using a Porter Cable model 7750 2 speed variable speed hammer drill alot recently. I was working fine drilling 1 inch holes in concrete until yesterday. First I noticed that it wouldn't run until I hit the starting trigger two or three times. Then I noticed it was slowing down and almost stopping while drilling. This is a very strong drill and I have drilled 9 12 inch deep holes without it slowing down once so I know there is something wrong. It's running too slowly now to be useful, and the shaft is turning freely and I don't feel any unusual play in the shaft.
The only thing I can think of right away is that the brushes may be worn out. Do these symptoms sound like that? Looking at the drill I don't see an obvious place where the brushes could be changed.
If anyone has had similiar experiences with a drill please let me know how you resolved it.
Thanks,
John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
http://www.acetoolrepair.com/PorterCableHTML/7750.htm
My guess would be bad variable switch. Since it won't travel enough to go into high speed region, the drill bogs down because it's running in slow mode.
jbclem wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.