Hitachi M12V Sticking

I just received a Hitachi M12V from Amazon and am shipping it right back. I'm very disappointed because I've heard mostly glowing reviews of the tool; great value, etc. Some of the reviews talked about the plunging mechanism sticking/being stiff. If it was just stiff I figured it would be fine because I planned to use it in a table most of the time. But with the one I received the problem is clearly that the threaded rod is rubbing the body of router. If forced the rod acts like a file on the body producing fine aluminum filings. If not forced the lock lever can be disengaged and the router body doesn't move at all. I removed the rod and things seemed fine. Was this a severe version of what others have experienced or do some also only have problems with stiff springs, etc. I would expect a tool of this size to feel stiffer than my 690/693 plunge base and it did without the rod in place. Either way, I think now it's a tool I'd want to see in person before trying again.
-Jim
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like you got a "drop" model. Any damage to the packaging?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:
[snipperized]

That's a piss-off, Jim. I have bought 5 of those by now (2 recondioned)... 3 for the shop (the business I sold in anticipation of retirement...yeahhh right...) and 2 at home. Never a problem. It's shipping thing, and certainly not indicative of the router's ruggedness or performance. I suggest to give Amazon another shot, cuz I know you'll be happy with the router.
00
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I have two and the last was from Amazon - no problems here. Yours might have been bounced along the shipping route. A GREAT router, IMHO.
Vic
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 19 Jan 2005 22:01:09 -0700, Jim Vidler wrote:

more severe version of reported problems. It sounds like yours was, as other's have suggested, dropped. The plunging was a bit stiff when I first pulled the thing out of the box, but it quickly loosened up. It was nothing like the problem you describe. Mine too was ordered from Amazon. I have had no problems and love the router. I have used it in my table and "freehand."
Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.