Warm house - cold radiator

I recently drained and refilled my CH system. After refilling and bleeding the rads all was well until the following morning when one radiator remained cold. There was no air in the top of the radiator and the pipes (microbore) were warm, I drew some water, and I think some air, off through the drain cock and the radiator heated up, however it has never heated up again without drawing more water through.
The system is open vented, the feed and expansion tank is full and clean(ish)
Any ideas? Help much appriciated
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The system is not balanced properly. Water is not getting to that rad because it's all going through the others. You need to close down the rad valves on each rad by the right amount to balance the flow through the system. I'm sure if you try an experiment by shutting all the other rads down you'll find this one heats straight up.
Dave Baker - Puma Race Engines (www.pumaracing.co.uk) I'm not at all sure why women like men. We're argumentative, childish, unsociable and extremely unappealing naked. I'm quite grateful they do though.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.