Bathroom Tap

Our cold water bath tap has been running slower and slower for the last couple of weeks. Today it was just trickling. Every other tap in the house is fine.
I took out the tap and changed the rubber washer, when I reinstalled it the tap wouldn't run at all. By undoing the head, water would flow at what I think is a normal rate.
I took the tap off again and had a look at the adjustment on the jumper/stem. I only managed in breaking an O ring so I though I'd ruined it completely and I don't have any spares in the house. Lo and behold, I put the tap back in again and it works perfectly.
My DIY book says that if the O rings are damaged water will bubble up through the top of the tap. I've had the water running for an hour and it's fine.
Have I just been lucky, or is impending doom on it's way and I'll wake up in the morning with a flooded bathroom?
Thanks in advance,
Darren
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How broken is it? A few dents you might get away with, with luck. If it actually tore, then I'd replace it PDQ, before you flood the bathroom. Get an assorted pack of O-rings from a nearby B&Q warehouse or plumber's merchants.
Christian.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.