Whirlpool toploader hit and miss engaging during spin

When it gets to the spin portion, sometimes the drum doesn't spin, though the pumps drain the tub. If I bump the selector knob off and on it always engages it and it spins fine. Some kind of clutch mechanism getting hitchy? How big a pain to fix/replace?
Thanks for all input
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Doc wrote the following:

Before you tear apart the control panel, check that the lid's cut-off switch is working properly. Maybe a loose wire or some other problem with it. If it's bad, it'll be the easiest and cheapest fix.
--

Bill
In Hamptonburgh, NY
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I noticed it doesn't seem to do anything. Tub spins with the lid open.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Doc wrote the following:

It shouldn't spin with the top open (unless you hold the lid button down). You can open the lid when it is agitating, or the rinse water is entering, or the water is draining, without shutting off the process, but when it is spinning, opening the lid should stop the process immediately. Leaving the lid open before the spin cycle starts will not allow the spin cycle to start at all until the lid is closed.
--

Bill
In Hamptonburgh, NY
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.