water pressure pump

Help,Our pressure pump is working eratic,it will pump up to 40 lbs like it supposed to and kick in at 20.The problem is that if the pump runs longer than 10 minutes the water pressure goes down to zero although it still pumps water(this pump is on a small pressure tank 3 gallons i think).As soon as you Quit running water it builts right up to 40 lbs and shuts off as normal.I thought it might be the water level but considering the rain we had i don't think this is the problem,also it is set up for deep well and the injector is in the well with a 1 inch and 11/4 hose.It does not seem to lose it pressure when watching the guage so i don't think it is the foot valve.I know a fair amount about pumps have always fixed my own but this has me stumped.Please help,By the way it is pretty cold up here in Ontario so am not looking forward to have to pull the line.Thank you Tom
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

3 gallon pressure tank seems kind of small for a home. My sister's house had an 82 gallon pressure tank.
How hard is your water? Maybe you have a sticky check valve that is not opening all the way, or your pipes have gotten smaller inside due to mineral build up. But it could be that your well is drawing down too far despite recent rains (it takes a while for water to filter into the ground).
--
David Efflandt - All spam ignored http://www.de-srv.com /
http://www.autox.chicago.il.us/ http://www.berniesfloral.net /
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.