Washing Machine Problem

I have a 10 yr. old Maytag washer (Model LAT5910BAW) and it has never had a problem. Suddenly it has started making a squishey noise when it pumps out water and then after the water is out and it is spinning, it gets very loud and it vibrates. The machine doesn't move around as in unbalanced load. But there is definitely a problem. It also leaks a little water at this point.
I need someone familiar with these machines to tell me approximately how much a new pump would cost installed. I may be wrong about what is causing the problem. Talked to the man who makes appointments. A diagnostic service call is $49 but if they work on it I pay parts and labor not the $49. If I buy new, from them, they take off $25. Their prices are higher than Lowe's and probably HD.
I have to decide whether it is wiser to try and fix this one or buy a new one. They can't send anybody out for at least a week because of the holidays. Any advice? Oh, and if I buy new: Maytag or Whirlpool? I will not be buying the top of the line.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

For some help try the following sites on Appliance Repairs MLD
http://www.applianceaid.com/index.html
http://www.repairclinic.com/0003.asp
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.