viessmann boiler trouble


So I've got a natural gas Viessmann boiler hooked up to my radiant hot water heating system. I'm currently having an intermittent problem. The thermostat is set at a certain temperature. The home temp drops and the thermostat calls. The boiler temperature is hot but the circulator pumps don't get turned on. If I leave it, it stays in this state. If I reset the boiler with the on/off switch or winter/summer switch then the circulator pumps start up. I watch the boiler temp lower, the boiler turns on and heats the water and the cycle of pump on and off starts. Eventually the house is at the right temp and everything is ok, for a while. Then a couple days later I'll find the temp has dropped again and it's the same problem: water is hot but pumps are not turned on to circulate.
Anyone ever heard of a problem like that? The switches are set to "on" and "winter" on the boiler. I've checked the current / voltage to the pumps while they are not circulating and it is definately zero. So the Viessmann boiler doesn't seem to turn on the circulator pumps.
What could be broken?
J
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
magnificient snipped-for-privacy@yahoo.ca wrote:

Typically, on drop past set-point, t-stat actuates relay to power circ-pump ; reverse on rise. Separate t-stat senses boiler temp and controls burner to maintain temp there. Different from furnace sequence.
I'd suspect relay.
You might want to contact pro.
J
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.