Stuck Switch on a Jet Pump


Hello
I have a Franklin convertible Jet Pump. Over the past month it has begun failing to come on. If I whack the switch housing with a screw driver it will start and then run fine for a while. Of course it usually quits when I am in the shower, most often just after I have begun shampooing.
Does anyone know if there is a fix for this or do I simply have to replace the switch?
Thanks in advance for any help you can give
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BillD wrote:

Buy and install the optional automated switch-housing whacker, or buy one for the marital unit for Christmas... :)
Assuming it's the pressure switch you're speaking of, failure is not uncommon and replacement is the only long-term solution as very few, if any, have replaceable contacts.
While at it, check that the pressure tap or small piping on which the switch is installed is clean and not full of rust or silt, etc., ...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Replace it.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BillD wrote:

DPD is right. Check that riser pipe as your first thing. Only takes a few minutes and a small pipe wrench. Note which wire goes on which terminal before removing.
If not that, then replace the switch. They are not spendy.
Harry K
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mine has contacts under the cover. A few times an insect has gotten in there and messed it up. I've also sanded the contacts with good results. The fact that it comes on when you whack the housing tells me something is hanging up your points- debris of some type.
Be sure to shut the breaker OFF when messing with things in there.
thetiler
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Replace it.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for all the replies! It turns out that one of the contacts is worn out and replacement of the switch is the only option - $29.00 at the hardward store :)
Thanks again
Bill
snipped-for-privacy@ISP.com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.