SQC Reverse Osmosis Drinking Water Appliance Problem

I am having a problem with my SQC Reverse Osmosis Drinking Water Appliance (w/o air gap).
I have been noticing that I barely get a single glass of water before it runs out. A few minutes later I get the same amount of water. It is as if its not pulling any water from the storage tank - I just get the water that is in the hose.
Last night I opened the storage tank and it was completely full. All the lines seemed to be clear. I emptied the tank and hooked it back up. The tank filled up and I am getting the same results.
Any idea what might be happening?
Regards
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You need to shut off the water to the RO and empty the tank and check the air pressure precharge. You use a tire pressure gauge to do that. I don't know what it would be for the make you have but usually it is somewhere around 5-7 psi up. The higher the pressure the less water is stored in the tank. The bladder may be broken in the tank and that would require a new tank, they are usually not replaceable. If you get water when you check the pressure, or when you leave air out with the valve pointed down, the bladder is broken.
Gary Quality Water Associates
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.