self-leveling underlayment didn't level?

I'm installing a ceramic tile floor in a bathroom.
The floor wasn't quite flat, so I bought two bags of latticrete "self-leveling" underlayment at the big box hardware store.
According to the directions, I just needed to pour it on and it would self level itself flat.
The problem is, it didn't level itself.
With a float and a lot of work, I got the floor fairly flat, but there are some high and low points.
Two questions:
1) Did I do something wrong or does this product not really work?
I did follow the directions on the bag.
2) How do I sand/grind down the underlayment at the high points to get it closer to level.
There is definitely an extreme hump in one area that has to be smoothed down before I lay the tile. It's too extreme to just level out the rest of the way with thinset.
Any help/suggestion is appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
use 36 or 50 g sandpaper with a pole sander or electric , " self leveling " its like an eat all you want diet, it still takes work.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Peter Palma wrote:

My best guess would be you didn't mix it thin enough. It should pour quite well and fill any low spots. I've used it severla times and only had problems when I used too little water.
RS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.