Scientific Atlant 4250HD - delay issues

Hi. I have a SA 4250HD receiver (just installed) and I'm having MAJOR issues switching between 480i and 1080i resolution channels. I have TWC as my HD provider. They had been charging me $8 per month for a HD receiver with DVR. I switched to the 4250 to save the $100 per year charge for something I didn't need/use. The reason I received the 4250 is that I use an HDMI connection between my receiver and TV. Evidently, this was my only option according to TWC. However, when I switch between HD channels (1080) and regular TV (480), the picture justifies to the left edge of the screen and the picture is actually worse than normal 480 resolution. With my old receiver, the 480 channels stayed in the CENTER of the screen with two black bars on the sides. It was perfect (for 480, i mean) - with no 'switching between resolution' problems I'm having now. The only way to get the 480 channels in the CENTER of the screen is to turn off the TV and turn it back on (which i believe just resets the signal sent from the HD receiver). Also, the 4250 receiver will NOT let me adjust aspect ratios because I'm using an HDMI connection. Whereas the old receiver allowed me to change/set the aspect ratios (forcing 480 resolution channels to 1080 aspect ratio - which 'centered' the picture on the screen). But now, with this new box, I do NOT have the ability to change the aspect ratios. Weird. Any help out there? I was thinking that if i bypassed the HDMI cable with component cables or something - just long enough to force the aspect ratios on the receiver, that this will alleviate the problem. PS - I can't keep the component cables hooked up because my conduit (which runs behind plaster walls) is not big enough to accommodate a whole slew of wires from the receiver, DVD player, etc. - which is partly why I'm using HDMI cables (the other part being that I THOUGHT my clearest reception comes from HDMI connections).
Thanks in advance for your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Can't you just set it to output one resolution so it doesn't switch? My plasma is 720p so I have my 8300DVR set to always output 720p. It upconverts automatically. If the 4250 can't do that ask for a 8000HD.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yeah, the 4250 doesn't 'permit' you to force the resolutions (which is really just forcing the aspect ratio) when you use an HDMI cable.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Forcing resolution on the 8300 HD is not related to aspect ratio. That is a separate setting. The 8300 can up and down convert resolution. To make channel switching faster, set it for one resolution and leave it there. If the 4250 can't do that see if they will give you the better model.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.