Resin in water softener drain

I have a water softener that was self installed almost 2 years ago and working without any problems till now. The valve on the tank is a Clack WS-1. Couple weeks ago, I happened to be checking the hoses on the drain and brine tanks and noticed that they were brittle and broken off, I am not sure how long this has been broken. No problem, Texas heat, I thought, I just cut off the bad brittle portion and reinstalled and manually did a regen, with no apparent problems. Today when I looked at the unit again, I noticed the brine tube and the drain broke off again, but this time I saw resin on the ground. Based on the gal left before regen display, I am guessing the regen cycle just happened last night. I have not seen any resin coming out of the faucets or toilets yet, but maybe it is too early for that.
Does anyone have any suggestions on what I should check and what precautionary measures I should take. I appreciate any response.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've answered this on my web site forum. He needs to protect the softener from direct sunlight.
Gary Quality Water Asociates
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.