Refrigerator water dispenser dripping after filter change


Just changed my water filter on the 6 year old Kenmore side-by- side...and now the water dispenser keeps dripping real slowly. I ran about 3 gallons of water through it to get the air out and the water pressure seems OK. Still keeps dripping, even removed the filter and that didn't help.
I assume this is some kind of shutoff value that isn't completely closing (not sure why installing a new filter caused it though). I really don't want to call the repairman on this one....
Is this an easy repair? My model number is 106.59592992. If it is the value, how do I identify where it is.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 5 Feb 2007 11:07:46 -0800, snipped-for-privacy@gmail.com wrote:

Your filter could be the problem. Stick the old filter back in and see it the leak stops. If it doesn't, then the electric valve is defective. Order a new one. Or first try taking it apart and cleaning it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

On my fridge the water dispenser dripped when there was any water in the line, it took a load of water to run thru before all the air was removed and the line stopped leaking, Try emptying out some more.
Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.