Oven not working


Oven: Magic Chef 31JN-2KLX-ON, Gas
I am trying to help my mom fix her oven, so the information I have comes through her. She says the oven has gradually taken longer and longer to light up. Now it does not light up at all, even after waiting for a couple of minutes. I know from looking at it myself that the stove top burners work fine. I know the electric igniter in the oven glows when you attempt to turn the oven on. I know the manual shut-off valve located under the "hood" is turned to the On position. The manual does not have a troubleshooting section. It looks to me that there are only two parts that could be at fault. It's either the igniter isn't getting hot enough to cause the gas valve to open or the gas valve isn't working. I would guess that just because the igniter glows doesn't necessarily mean it is working properly. Any suggestions guys?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

www.repairclinic.com Yes, it can still glow but not work properly.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
http://applianceguru.com /
ATL wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
buffalobill wrote:

That's correct. Unless it's glowing quite brightly, my guess is it's the igniter -- it's a common problem.
Any suggestions guys?

--
The e-mail address in our reply-to line is reversed in an attempt to
minimize spam. Our true address is of the form snipped-for-privacy@prodigy.net.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Pull the oven and see if there's a technician's sheet hidden in there, or inside one of the panels. That has the secret you are seeking, Grasshoppa.
Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ATL wrote:

on the igniter it should be a little over 3 amps.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just a followup. We replaced the igniter and that was the problem. Thanks to all who responded.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.