oil furnace problem


Hi,we own an oil furnace and we started using it in this winter but the problem starts when the furnace do all the process , when the flame shut off you can see the smoke coming from chamber electrodes and the nozzle when I open the cap I see few drops of oil. I call a mechanic he change the nozzle, the head and the oil filter but it still doing the same thing I dont think is the oil pump because the mechanic come back to my house and the furnace is doing the same thing so I can't use it. I feel bad because I call a company and never fixed the furnace what can I do?
--
Send from http://www.nonsolonews.net

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Does it ignite and heat the house, if so, a couple of drops of oil after shut-off is no need to panic. If it is still malfunctioning and the repair people agree that it is not functioning properly I would call whoever did the repairs and tell them they didn't fix it and they should come back at no cost to you to fix it properly.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 12/27/2009 10:24 PM, sasha35 wrote:

Sounds like the shut off valve is not working. It is supposed to shut so the coasting of the pump to a stop will not pump oil.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.