No power to burners or oven but control panel works

The power went off/on this morning. Now my oven control panel works fine, but there is no power going to any of the burners. I took off the back cover but could not find any fuse or circuit breaker. I can post pictures .
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Dec 31, 11:06 am, snipped-for-privacy@mynonsense.net wrote:

Sounds like have 110 but not 220 -- first go trip/reset the breaker at the panel manually. Post back result if doesn't fix w/ model/ manufacturer/etc. details.
--
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Dec 31, 11:06 am, snipped-for-privacy@mynonsense.net wrote:

One leg of your 240 V supply to the oven/stove is dead. Go to your service entry box and turn the stove breaker off, then on. If that fixes the problem, everything may be in working order. If not, then if you have a voltmeter or test lamp check both breaker connections for voltage to ground. If OK, the problem is at the appliance connections. With power off, check for loose wire connections and such. If all this is not something you feel confident to deal with, call a qualified electrician. Good luck.
Joe
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Dec 31, 12:06 pm, snipped-for-privacy@mynonsense.net wrote:

Sounds like one of the phases is dead. Your control panel works because it works off of one of the phases. Check the elect panel. It could be that your oven is on 2 seperate breakers instead of the usual double pole breaker, so one of the breakers might have tripped. If it looks good, check for voltage at the stove.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Dec 31, 11:06 am, snipped-for-privacy@mynonsense.net wrote:

Thanks, the problem was that one of the transformers in our complex went out. So maybe that was why there was no 240v for a period in the day?
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That would do it.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.