Magic Chef Forced air furnace fan not getting power

Folks,
Perhaps you can help. I suspect with all the experts here the answer is yes.
I have a Magic Chef Forced air furnace model# 0100-2.
Just turning it on for the first time this winter. It comes on just fine but the fan/blower is not coming on.
I took the front off and examined it. The fan does work (I ran power to it and it came on just fine). I also can hear the solenoid/relay (what is it?) open when the unit reaches 105degrees after about 1-2minutes (the setting on the temp gauge). So the various parts appear to workjust that power is not getting to the fan. The wiring is correct and when I disconnected the lines from the temp gauge to the fan and applied power the fan worked just fine.
Any ideas on what the problem might be?
Thanks in advance!! -D
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you are hearing the "solenoid/relay" kicking in, then you want to make sure it has 110V to it and then check to see if it is really making contact. They can fail in such a way that they click, but don't make contact. Also suspect is the wire from the relay to the fan. (is this a multi-speed fan?) did you check out that speed?
--
Joseph E. Meehan

26 + 6 = 1 It's Irish Math
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.