Looking for help with 2-stroke engines please.

I have a WEED EATER PE550 edger (with steel blade).
Also a WEED EATER FL21 (Lightweight string trimmer).
They both have a spark and good compression but only run for 5 - 10 seconds.
I took the carb off the PE550, blew it out with an air hose, then soaked it overnight in 'carb cleaner'and blew it out again.
This made NO difference to how it ran so I bought a brand new carb. It, too, made NO difference at all, so I bought a brand new filter which, again, made NO difference.
Next I attacked the FL21 which also only runs for 5 - 10 secs. and replaced the fuel lines. but still NO difference. I then blew out the filter but still NO difference.
I would appreciate it if you have a suggestion for me.
TIA
Lewis *****
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 10 Aug 2012 06:18:47 -0700, snipped-for-privacy@gmail.com wrote:

Blocked breather? Try a test-run with the filler cap off and see if that makes a difference.
Also, these probably run the fuel pump via a port in the crankcase - potentially that can get blocked (or the gasket between carb and he rest of the engine doesn't seat properly and either leaks or blocks)
cheers
Jules
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'd guess you're feeding them both from the same batch of two stroke gasoline? I'll admit, I don't know for certain sure. But, it's a good guess that since both display the symptoms, the culprit is what they have in common, being your gasoline supply.
For science, please pour that batch of gas into your car's gas tank. Go buy a gallon of premium, with no ethanol (if such can be found). Mix the oil, and see if that works better.
That's what comes to mind. Hope that helps. Please write back, in either case.
Christopher A. Young Learn more about Jesus www.lds.org .
I have a WEED EATER PE550 edger (with steel blade).
Also a WEED EATER FL21 (Lightweight string trimmer).
They both have a spark and good compression but only run for 5 - 10 seconds.
I took the carb off the PE550, blew it out with an air hose, then soaked it overnight in 'carb cleaner'and blew it out again.
This made NO difference to how it ran so I bought a brand new carb. It, too, made NO difference at all, so I bought a brand new filter which, again, made NO difference.
Next I attacked the FL21 which also only runs for 5 - 10 secs. and replaced the fuel lines. but still NO difference. I then blew out the filter but still NO difference.
I would appreciate it if you have a suggestion for me.
TIA
Lewis *****
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 10 Aug 2012 06:18:47 -0700 (PDT), " snipped-for-privacy@gmail.com"

made NO difference at all, so I bought a brand new filter which, again, made NO difference.

fuel lines. but still NO difference. I then blew out the filter but still NO difference.

After all of that-- Was the first thing you tried- dumping the gas-- including the gas in the can and mixing up a new batch with fresh gas?
Jim
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Two devices, same symptoms, same day of the year. What do they have in common?
Christopher A. Young Learn more about Jesus www.lds.org .
After all of that-- Was the first thing you tried- dumping the gas-- including the gas in the can and mixing up a new batch with fresh gas?
Jim
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 10 Aug 2012 06:18:47 -0700 (PDT), " snipped-for-privacy@gmail.com"

made NO difference at all, so I bought a brand new filter which, again, made NO difference.

fuel lines. but still NO difference. I then blew out the filter but still NO difference.

spark when it dies.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Friday, August 10, 2012 8:18:47 AM UTC-5, snipped-for-privacy@gmail.com wrote:

made NO difference at all, so I bought a brand new filter which, again, made NO difference.

the fuel lines. but still NO difference. I then blew out the filter but still NO difference.

Thanks for your interest.
I tried to check the filler cap by turning the cap upside down, putting a few drops of gas into it and looking for it to drip out, which it didn't. I can see the brass colored mesh and it appears to be clean.
Cranking on the engine with the cap removed looks a little risky to me with the way the gas tank is mounted.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

at least try it!!!!!!!!!!!!!!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.